Issues accessing EHR

Incident Report for RXNT

Resolved

We are continuing to monitor for any further issues.
Posted Mar 23, 2026 - 15:48 EDT

Update

We are continuing to monitor for any further issues.
Posted Mar 23, 2026 - 15:41 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 23, 2026 - 15:37 EDT

Identified

A small number of accounts are experiencing issues accessing the EHR product.

The engineering team has identified the issue and is actively working on a resolution.
Posted Mar 23, 2026 - 15:28 EDT
This incident affected: Electronic Health Records (Prescriber Dashboard).