Billing: Payments stuck in "In-Progress" tab

Incident Report for RXNT

Resolved

This incident is resolved.
Posted Apr 08, 2026 - 09:45 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2026 - 09:38 EDT

Update

We are continuing to investigate this issue.
Posted Apr 08, 2026 - 09:38 EDT

Investigating

The posted insurance payments are getting stuck in the "In-Progress" tab.
Posted Apr 08, 2026 - 09:36 EDT
This incident affected: Practice Management (Insurance Payments).