Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 20, 2026 - 10:45 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 17, 2026 - 12:18 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 17, 2026 - 12:17 EDT
Scheduled
We will be performing scheduled maintenance to implement enhanced security measures across our platform. These upgrades are part of our ongoing commitment to keeping our systems and your data safe.
What to Expect: While the platform will remain online, these security updates involve stricter traffic filtering. As a result, you might notice the following during or after the maintenance window:
- Access Adjustments: In very rare cases, standard user access might be temporarily restricted or challenged by our new security filters.
- Integration Interruptions: Automated processes or third-party tools connected to our platform may experience brief connection issues.
If you find yourself unexpectedly blocked from accessing the site, or if your automated integrations stop functioning as expected after the update, please reach out to our support team immediately so we can adjust the filters for your account.
Posted Apr 17, 2026 - 12:12 EDT
This scheduled maintenance affected: ERX (Electronic Prescribing of Controlled Substances, Real Time Prescription Benefit(RTPB), Prescription Drug Monitoring Program (PDMP) Service, Prescriptions), Practice Management (Claims, Electronic Remittance Advice (ERA), Patient Payments, Reports, Billing Encounter, Statements, Patients, Eligibility, Insurance Payments), and Scheduler, Client Login, RXNT Customer Service, Mobile Apps, RXnotify App, EHR Login, Dashboard Login, AI Features.