Patient Payments
Incident Report for rxntapps
Resolved
This incident has been resolved.
Posted Jan 03, 2024 - 18:03 EST
Investigating
Our team is aware of an issue with processing patient payments. We're investigating and will provide an update as soon as possible. We apologize for any inconvenience this causes.
Posted Jan 03, 2024 - 12:23 EST
This incident affected: Practice Management (Patient Payments).