Claim Errors
Incident Report for rxntapps
Resolved
This incident has been resolved.
Posted Dec 18, 2023 - 13:29 EST
Update
Connectivity with Change Healthcare is down. Change Healthcare team is looking into the issue.
Posted Dec 18, 2023 - 10:14 EST
Investigating
Our team is aware of an issue impacting the Claims functionality. We're investigating and will provide an update as soon as possible. We apologize for any inconvenience this causes.
Posted Dec 18, 2023 - 10:12 EST
This incident affected: Practice Management (Claims, Electronic Remittance Advice (ERA)).