Prescriptions Functionality
Incident Report for rxntapps
Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 11:55 EDT
Investigating
Our team is aware of an issue impacting prescriptions functionality within E-Prescribing. We're investigating and will provide an update as soon as possible. We apologize for any inconvenience this causes.
Posted Mar 20, 2024 - 10:56 EDT
This incident affected: ERX (Prescriptions).