Report Processing
Incident Report for rxntapps
Resolved
This incident has been resolved.
Posted Dec 30, 2023 - 18:28 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 30, 2023 - 18:13 EST
Investigating
Our team is aware of an issue with processing Reports. We're investigating and will provide an update as soon as possible. We apologize for any inconvenience this causes.
Posted Dec 30, 2023 - 17:47 EST
This incident affected: Practice Management (Reports).