Clients not able to connect to RXNT
Incident Report for rxntapps
Resolved
This incident has been resolved.
Posted Sep 12, 2024 - 10:08 EDT
Investigating
Clients using AT&T networks might have issues connecting to RXNT. Our service provider is currently investigating the issue.
Posted Sep 12, 2024 - 09:33 EDT
This incident affected: RXNT.com.