Claim Errors
Incident Report for rxntapps
Update
We are continuing to monitor for any further issues.
Posted Apr 18, 2024 - 14:42 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 15, 2024 - 09:01 EDT
Investigating
Our team is aware of an issue impacting the Claims functionality. We're investigating and will provide an update as soon as possible. We apologize for any inconvenience this causes.
Posted Feb 21, 2024 - 07:26 EST
This incident affects: Practice Management (Claims).