Application Access
Incident Report for rxntapps
Resolved
This incident has been resolved.
Posted Dec 29, 2023 - 11:41 EST
Investigating
Our team is aware of an issue preventing users from accessing the application. We're investigating and will provide an update as soon as possible. We apologize for any inconvenience this causes.
Posted Dec 29, 2023 - 09:56 EST
This incident affected: Client Login.