Clinical Encounter Issue
Incident Report for rxntapps
Resolved
This incident has been resolved.
Posted May 08, 2024 - 11:24 EDT
Investigating
Our team is aware of an issue impacting the encounter functionality. We're investigating and will provide an update as soon as possible. We apologize for any inconvenience this causes.
Posted May 08, 2024 - 08:17 EDT
This incident affected: Electronic Health Records (Clinical Encounter).