Clinical Encounter Issue
Incident Report for rxntapps
Resolved
This incident has been resolved.
Posted Feb 21, 2024 - 20:30 EST
Update
We are continuing to investigate this issue.
Posted Feb 21, 2024 - 18:05 EST
Investigating
Our team is aware of an issue impacting the encounter functionality. We're investigating and will provide an update as soon as possible. We apologize for any inconvenience this causes.
Posted Feb 21, 2024 - 18:04 EST
This incident affected: ERX (Electronic Prescribing of Controlled Substances, Real Time Prescription Benefit(RTPB), Prescription Drug Monitoring Program (PDMP) Service, Prescriptions) and Electronic Health Records (Referrals, Clinical Encounter, Fax, Labs).