Lab Service Issue
Incident Report for rxntapps
Resolved
This incident has been resolved.
Posted Nov 18, 2024 - 17:53 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2024 - 14:03 EST
Investigating
Our team is aware of an issue impacting the clinical lab functionality. We're investigating and will provide an update as soon as possible. We apologize for any inconvenience this causes.
Posted Nov 18, 2024 - 01:00 EST
This incident affected: Electronic Health Records (Labs).